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1. Introduction

MEZ® takes its name from the Muses of Greek mythology. A Muse was a goddess who inspired the creation process
for the arts and sciences. Like its ancient Greek namesake, the PEZ® platform inspires rapid development by
supplying customers with an extensive library of open source software, drivers, and processor support - all under a
common framework. LEZ® development works on the premise of “design once, reuse many times”. This provides
an open source standard for embedded developers to build upon and support. HEZ® allows companies to focus on
innovation and on their own value-added applications while minimizing development time and maximizing

software reuse.

The diagram below shows a typical embedded application stack. LEZ® has three primary categories of components
that help simplify embedded application development:

1. Operating System Abstraction Layer (nEZ® OSAL)
2. Sub-system drivers (0nEZ® TCP/IP, pEZ® USB, pEZ® Driver)
3. Hardware Abstraction Layer (nEZ® HAL)

Applications

wEZ® OSAL

uEZ® TCP/IP nEZ® DRIVER

Host . '-hCD
Device oucnscreen

File System
OTG 12C, SPI, Etc.

FreeRTOS™

uEZe HAL

‘ Hardware Peripheral API ’

Embedded Microprocessor ’

The selection of an RTOS can be one of the most daunting aspects of an embedded system development. With
MEZ® the primary features of common multi-tasking operating systems are abstracted, thus easing the transition to
an open source or low-cost RTOS. The HEZ® OSAL provides applications access to the following features in an OS-

independent fashion:

e Pre-emptive multitasking e Queues
e Stack overflow detection e Semaphores (binary, counting, mutex)
e Unlimited number of tasks

The MEZ® sub-system drivers utilize the OSAL functions to provide protected access to the processor
peripherals. The sub-system driver API functions are typically protocol layer interfaces (TCP/IP, USB, etc)
designed as high-level access routines such as open, close, read, write, etc. where possible.



The HAL functions provide single-threaded unprotected access to the processor peripherals. Customers can

use the MEZ® HAL routines provided by FDI or they can write their own. The HAL routines provide for

RTOS/MEZ® independence and allow portability within a family of processors.

MEZ® is ideally suited for Embedded Systems with standard features such as:

e Processor and Platform BSPs
(Board Support Packages)

e Real Time Operating System (RTOS)

e Memory Management

e NAND/NOR Flash

e SDRAM and DDR Memory

e TCP/IP stack

e USB Device/Host Libraries

e Mass Storage Devices

e LCD Displays with Touch Screen

e Input/ Output Devices

2. Downloading ugz’

Start by downloading the latest version of uEZ® from https://sourceforge.net/projects/uez/. Unzip to a working folder.

In this document we will use a simple directory structure of /uEZ but the user is free to modify this as desired.

The ukZ® file directory structure should be as follows:

Directory Description
/Build Projects/makefiles for different applications/demos
/Include UEZ® system files and Config.h

/Include/Device

Device Driver class definitions.

/Include/HAL

Hardware Abstraction Layer (HAL) driver class definitions.

/Include/Types

Common data types used by both HAL and Device Drivers.

/Source Source code

/Source/App User application source code and demos shared among
multiple builds.

/Source/BSP BSP generic startup code

/Source/Devices/<category>/<manufacturer>/<device>

Device specific code organized by category (12C, SSP, etc.),
manufacturer, and specific device.

/Source/Library/<category>/<package>

Various support libraries organized by category (graphics, file
system, etc.) and package name.

/Source/Platform/<manufacturer>/<platform>

Platforms/boards code organized by manufacturer and specific
platform build.

/Source/Processor/<manufacturer>/<processor>

Processor specific code in separate directories organized by
manufacturer and specific processor.

/Source/RTOS/<RTOS>/

RTOS source code in separate directories

/Source/uEZSystem

UEZ® System Core routines




3. Project Configuration

UEZ® uses a simple one project configuration. Depending on the compiler tools, use one of the following subsections.

Preparing the uEZ® Source Code
Download the uEZ® v1.11 (or later) source code from http://www.sourceforge.net/projects/uez. Unzip the file to where

you will be working. It should create a folder called /UEZ_SRC.

Rowley CrossWorks CrossStudio v2.0 Project Configuration
Check CrossStudio Version

UEZ® is built using v2.0, or later, of the Rowley CrossWorks CrossStudio for ARM® toolset. To confirm the version
number of the tools, go to Help->About in the main menu and the version number should appear in the middle of the
dialog.

Rowley
CrossWorks

Build versions of 2.0.x are acceptable.

Check Installed Packages
In addition, packages for your target processor(s) should be installed. Go to Tools->Show Installed Packages and see

which packages have been installed. For example,

Installed Packages

The following support packages have been installed, click on the links to get mare information on each package and its contents:

Paclkage Version Status
Generic ARM CPU Support Package 1.2 Installed
MXP LPC1000 CPU Support Package 1.7 Installed
MXP LPCZ000 CPU Support Package 1.30 Installed

If doing development for the DK-TS-KIT with the SOMDIMM-LPC2478, the following packages should be installed:
Generic ARM® CPU Support Package
NXP LPC2000 CPU Support Package

If doing development for the DK-TS-KIT with the SOMDIMM-LPC1788, the following packages should be installed:
Generic ARM® CPU Support Package



NXP LPC1000 CPU Support Package

If the packages are not installed, go to Tools->Download Packages from Web, download the missing packages, and then
use Tools->Install Package... to install them.

Opening and Compiling uez’

Open the one project build files in the /uEZ/Build directories. For example, when working on the DK-57TS-LPC2478,
open /uEZ/Build/DK-TS-KIT/DK-TS-LPC2478/FDIDemo/CrossWorks 2.0/DK-TS-LPC2478 uEZDemo.hzp. The Project
Explorer should appear at the right showing all the files in the project. The ukZ distribution comes with the uez
Demonstration Application in the /uEZ/App/UEZDemo directory and is configured for the DK-57TS-LPC2478 kit. If you
need to change the LCD configuration, open the file Config_Build.h to change which LCD to use.

To compile the code for the first time, select Build->Rebuild uEZ from the main menu. When complete, the output
should report “Build up to date” when done.

Downloading and Debugging uEZ® on the Target
1) Plug the J-Link device into the PC and install any drivers as directed. The Segger J-Link drivers can be found at

http://www.segger.com/cms/jlink-software.html with additional information at

http://www.segger.com/cms/development-tools.html.
2) Plug the J-Link’s JTAG cable into the target (e.g., SOMDIMM-LPC2478’s J3 connector).
3) Power on the target board.
4) Select Target menu and choose Targets. The following list will appear to the right.

|
PR

% UUSB CrossConnect for ARM

USB CrossConnect for ARM-RTCK

#2 Macraigor Wigdler (20 Pin)

# Macraigor Wigdler (14 Pin)
Olimex ARM-USB-OCD
Olimex ARM-USE-TINY
Amontec JTAGKkey
xVerve Signalyzer
Luminary IUSE Debug

STRS-comStick

Segger J-Link

@ ARM Simulator

5) Right click on “Segger J-Link” and select Properties,

[55] 8 | G] e staoer ok Procees

[ Debug btednce Type: ARMITDH
2] Memory Access Trreot LI00 milwecondy
&) Processor Byle Order. Ll

1 Frecnsser Stop Temeoue 500 miseconds



6) If this is the first time you are programming with the J-Link on the Rowley Platform, select J-Link DLL File, press
the “...” button and find the file JLinkARM.dII (usually installed in C:/Program Files/SEGGER/”)

7) If programming a blank LPC2478 part, select a Speed of 100. If the LPC2478 has already been programmed,
select a Speed of 1000. All LPC2478’s that come with the DK-xTS-LPC2478 are pre-programmed.

8) Go back to menu Target and select “Connect Segger J-Link”

9) Press F5 to download the application to the target and start debugging. When the application starts, it will
pause. Press F5 again to start executing the code.

10) To stop at any line of code, right click the line and select Toggle Breakpoint. Execution will stop automatically at
the breakpoint. Press F5 again to continue debugging.

11) When done debugging, select Debug->Stop. The debugger will return to standard editor mode.

12) From this point on, the process is simply a matter of editing code, compiling the code (Build->Build ukZ or
pressing F7), and then running the debugger.

IAR Systems Embedded Workbench v6.10 Project Configuration

Check IAR Version
UEZ® is built using 6.10, or later, of the IAR Embedded Workbench Toolset. To confirm the version number of the tools,

go to Help->About->Product Info in the main menu and the version number should appear in the middle of the dialog.

Product Info

h 0K
:}'@ |&F Embedded “Workbench -
Productdetals: .
| 114442010 3:00:32 PM, 212992 bytes A
18R Archive Tool

9.7.1.24 (9.7.1.24)
C:%Program FileshAR Systemz\Embedded Workbench B.0%armibintiarchive exe
10/29/20101:05:14 PM, 1529856 bytes

|&F Azsembler for AFRM
£.10.1.52143 [6.10.1.52143)
C:\Program FileghAR SystemshEmbedded Workbench B.0Marmbinhiasmarm, exe
10/29/2070 1:09:10 PM, 2451456 bytes

|8F CAC++ Compiler for AR M
£.10.1.52143 [6.10.1.52143)
C:\Program FileghlAR SystemshEmbedded Workbench B.0\armbinhiccamm. exe
1042942010 1:03:18 P, 25134080 bytez

|&F ELF Durnper faor ARM
£.10.1.52143(6.10.1.52143) e |

|i£ .
Copyright 2002-2010 [A4F Systems AB.

IAR C/C++ Compiler for ARM 6.10.1 and greater are acceptable.

Opening and Compiling uEZ®
Open the one project build files in the /uEZ/Build directories. For example, when working on the DK-57TS-LPC2478,

open UEZ\Build\DK-TS-KIT\DK-57TS-LPC2478\IAR6.10\ DK-57TS-LPC2478.eww. The Project Explorer should appear at
the left showing all the files in the project. The uEZ distribution comes with the uEZ Demonstration Application in the
JUEZ/App/ DK-TS-Demo directory and is configured for the DK-XXXTS-LPC2478 kit, in this case DK-57TS-LPC2478.



To compile the code for the first time, select Project->Make from the main menu or press F7. When complete, the
output should report “Total number of errors: 0” when done.

Downloading and Debugging uEZ® on the Target
1) Plug the J-Link device into the PC and install any drivers as directed. The Segger J-Link drivers can be found at

http://www.segger.com/cms/jlink-software.html with additional information at
http://www.segger.com/cms/development-tools.html.

2) Plug the J-Link’s JTAG cable into the target (e.g., SOMDIMM-LPC2478’s J3 connector).

3) Power on the target board.

4) The project is preconfigured for the Segger J-Link. If the J-link software is installed after IAR the dll will
automatically be updated. Otherwise run the SEGGER J-Link Updater from SEGGER/J-Link ARM vx.xx in the start

menu.

2 SEGGER J-Link DLL Updater V4.26b Pz|

The following 3rd-party applications using JLinkaRM. dll have been found

[114R Embedded Warkbench far ARM 6.10 (DLL %4.26b in "C:\Program Files\&R SustemshEmbedded Workbench B.0%ARMbin']
[114R Embedded wWarkbench far ARM B.10 [DLL ¥4 2Bb in "C:\Pragram FileshAR SystemshEmbedded Workbench B.0_2WARMAbin'"]

Select Al Select Mane

Select the ones you would like ta replace by this version.

The previous verzion will be renamed and kept in the zame folder, allowing manual "unda®.
In case of doubt, do not replace existing DLL[s).

‘Y'ou can always perform this operation at a later time via start menu.

Cancel |

5) Select Project->Download and Debug from the main menu or Ctrl + D to start debugging.

bedded Workbench IDE

Wiew NEGEES Tools  Wwindow  Help

ﬁ Add Files. ..
Add Group, .. i<
Edit Configurations. .. L
-57T
Includ  Create Mew Project...
Soyrg  Add Existing Project...
JAp Options... AlE+F7
a0l
FE1[  Source Code Contral 3
T Make F7
[ | Rebuid all
Clean
Batch build, . F3

d and Debug Chrl+D

Debug without Downloading

Dovenload 3

L— M Cvarrar Tamh

6) Debugging control can be operated from debug toolbar.

'u*:l r"ﬁ.-*—PI*'*'*
[ o T AW S



7)

When finished debugging press the red X in the debug toolbar.

Configuring Renesas HEW for J-Link Flashing

1)
2)

3)
4)

5)
6)

7)

See the document “uEZ® Software Quick start Guide” for details on how to download the uEZ® source code
Plug in the J-Link device into the PC and install any drivers as directed. If necessary, download the drivers from
http://www.segger.com/cms/jlink-software.html?step=1&file=JLink 426a

Plug in the J-Link’s JTAG 10-pin connector (J2) to the SOMDIMM board connector (CN1) with the JTAG adapter.
If a workspace has not been opened, go to /uEZ_SRC/Build/DK-TS-KIT/DK-57TS-RX62N/RenesasRX and open file
“DKTSKITDemo_RX62N.hws” or any other existing workspace.

Build the code if not already using Build->Build or by pressing F7.

Open Debug->Debug Sessions. Under Current Session, select “SessionRX600_Segger J-Link” and click OK. Some
older compiler configurations do not have this option. If this is the case, use “SessionRX600 E1 E20_SYSTEM”.
If asked to save the previous session, click No.

E

Debug Sessions

Debug sessions:

Add...
SessionRXE00_E1_E20_SYSTEM g
SessionRxE00_Segger_J-Link
Remove
Save as.
Properties.

Current seszion:

The following dialog will appear. Make sure the MCU group is “RX62N Group” and Device is “R5F562N8”. On
the Communication tab, the JTAG Clock is 16.5 MHz. Press OK.

Initial Settings [
Device | Commurication |
MCU group: hd
Device:  |R5F562NE =l
Mode
& Debugging mede
-
" Witing the on-chip flash memory mode
s
Paower supply
=
(g (o)
Commurnication
Emulator
Serial No.: | _Befesh
=
[~ Do not show this dialog box again




8) The Configuration Properties will appear. Confirm the Operating Mode has a Mode of “Single-chip mode” and
Input clock (EXTAL) is “12.0000” MHz. The other tabs (Internal flash memory, External Flash memory, and
System) use the default values. Then press OK to connect to the unit.

Configuration Properties &J
Intemal flash memory overwite | Extemal flash memary |
L= — Sysem

Operating mode

Mode:  |Single-chip mode =
Endian: ‘Lvttle endian J
Input clock (EXTAL): |12.0000 MHz

Extemal memory areas

Ares Endian BUS Width

< m b

‘Work BAM start address ((<400 i

bytes used): 100
oK Cancel

I Do not show this dialog box again

9) No errors should appear. The unit is now connected. The next step is to download the code. If the code has
been compiled, scroll down in the project explorer and find the image file under “Download modules”. For the

DKTSKitDemo code, the file “DKTSKITDemo_RX62N.abs” should be listed. Right click on this file and select
Download.

[T ——
uEZTimeDate.c
uEZToneGenerator.c
UEZTS.c

=3 Dowrload modules

[) DKTSKITDemo_RX62N abs - 00000000
=-£9 Dependencies
B

Mccelerometerh
Mccelerometerh
Accellconh
Accellcon128h
ADCh
ADCBarkh
ADCBarkh
apih

api_msgh
AppDemoh
AppFoldericon h
AppFoldericon 128h

"~ {F Projects @ Templaes | ] Nawigston Test |
=
d

&2 =]
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10) The following window should appear. Select Debug->Run (F5) to start execution.

2+ C:\FDIWEZ\SWA...\Renesas\RX62N\RXT oolset\resetprg.c - Read-Only =)
B8E
Line Source Ad... | O.] §.| Source |
71 //#ifdef _ cplusplus // Remove the comment when u use global class :bjej
T2 //extern "C" // Sections C$INIT and C$END will be generated
73 [
T4
75
T8
77 I
78 /f#endif
73
80 #pragma section ResetPRG
81
82 #pragma entry PowerCH_Reset_PC
a3
84 |FFF80400 o woid PowerON Reset PC(void)
8 {
26 |FFFB040E set_inth((unsigned long)__sectop("CSVECT")):
87 |[FFF80417 set_fpsw (FPSW_init);
89 |FFFB041E _INITSCT():
Q0
91 |FFFB0422 _INIT_ICLIE(); // Use SIM I/C
a2
a3 = 10
a4 7 n INT) 1) ; 7 v e rand()
95 iptr : // Rem use strtok()
k=1 -

4. Questions and Support

For all questions, bug reports and general technical support, go to https://sourceforge.net/projects/uez/ and use the

Sourceforge.net tools or email FDI directly at support@teamfdi.com . A support forum is also provided at

http://www.teamfdi.com/forum/ .

Marketing updates and details on technical support are available at www.teamfdi.com/uez .

Can we use another RTOS?

All LEZ® components are made to connect through the pEZ® OSAL (Operating System Abstraction Layer) to the RTOS
ensuring compatibility with many different RTOS'’s. Currently all LEZ® development by FDI is being focused on the
FreeRTOS™ platform since it satisfies the low cost tool requirement because it is “free”. RTOS products from other
vendors can also be used with WEZ®.

Which compiler suites do you support?
Currently, most PHEZ® development by FDI has been focused on the low cost Rowley CrossWorks compiler, but we also
support the IAR EWARM tool suite. In addition, Keil, ARM® RealView, GNU and other compilers can be used with pEZ®.

What debug tools are available?
Since MEZ® uses the debug tools that are provided in the customers compiler suite, it can be used with any of the tools
listed above.

Which processors are supported?

Even though MEZ® is processor independent, all of our initial development has been focused on various members of the
ARM Family. We currently support the NXP LPC24xx family, the NXP LPC17xx, and processors like Cortex™-M3, and
other variations of ARM7® are being added.
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